Foro Hospedaje y Dominios Foro Hospedaje y Dominios
Nueva Discusión

¡Hola Forastero!

Pareces nuevo por aquí. Si quieres participar, ¡pulsa uno de estos botones!

Acceder con Facebook Acceder con Google Acceder con OpenID Acceder con Twitter
Instalar Mambo-Joomla con compatibilidad con installers
  • Aprovecharemos que en nuestro panel de control podemos instalar la última versión de mambo o joomla cómodamente (y otras muchas aplicaciones) a través de Installatron . Buscamos la siguiente opción en nuestro panel de control y entramos en ella.
    [center][Foto 1] *

    Una vez dentro Installatron es lo suficientemente claro y con instrucciones en castellano para que lo instalemos rápidamente sin problemas. Seleccionamos mambo entre la multitud de aplicaciones disponibles y pinchamos en el botón Nueva Instalación . Una vez allí hay que decidir si queremos que el mambo o joomla carge directamente cuando se teclee nuestro dominio en el navegador, en cuyo caso hay que indicar que la instalación sea en el raíz (/) o en un directorio (/mambo o /joomla) , si elegimos esta última opción y queremos que nuestro site vaya a esa carpeta acordarse de poner un redireccionador automático en el raiz hacia ella

    [center][Foto 2]

    Si tenemos claro la aplicación con la que vamos a trabajar la opción recomendada es instalar la aplicación en el raíz.

    El único problema que da el modo seguro es que la instalación de componentes , módulos y templates hay que hacerla manual . Para que se pueda hacer directamente indicando el fichero en nuestro ordenador hay que aplicar un parche para el modo seguro . Lo descargaremos aquí :

    Mambo_4.5.1_Safemode_Patch_v1.0.zip80 KB5,419Any.zip

    Nota : Este parche vale también va también perfecto para la versión 4.5.2, 4.5.3, 4.5.4 de mambo y versiones anteriores a la 1.0.10 de joomla.

    ACTUALIZACION, parche para joomla 1.0.10 y superiores (ver también esta nota - gracias monki) : http://developer.joomla.org/sf/frs/do/listReleases/projects.safejoomla/frs.safejoomla_1_0_10;jsessionid=04770D259686B551C56C424BD54DD761

    NUEVA ACTUALIZACION, parche para joomla 1.0.11 y superiores:
    http://developer.joomla.org/sf/frs/do/downloadFile/projects.safejoomla/frs.safejoomla_1_0_11.safejoomla1_0_11/frs6829?dl=1


    Una vez descomprimido en nuestro ordenador ese zip extraemos la carpeta administrator y despues la subimos al raíz de nuestro mambo por ftp, de tal modo que se sobreescriban los ficheros actuales por los del parche.

    Si hemos instalado bien el parche veremos en la página de instalacion de módulos, componentes etc un texto en inglés y nuevas opciones :

    [center][Foto 3]
    [/center]

    Simplemente hemos de marca la casilla Use Ftp Assist y poner nuestro usuario y contraseña y nuestro dominio (los del acceso por ftp). Despues abajo seleccionamos el modulo o componente a instalar (que estará en el disco duro local) y pinchar en Upload file and install (subir fichero e instalar) . Esto permitirá instalar ya cualquier cosa sin ningún tipo de problema , dejará todo con los permisos correctos y en su sitio.

    [/center]

    [/center]
  • ;) Gracias, el parche funciona perfectamente con joomla 1.0.4
    Saludos
  • En http://pranab.altiuscorp.com/ hay parches para joomla que funcionan a la perfección, supongo que será mejor que usar uno que se hizo para el viejo mambo.

    Solo una cosa con estos parches, hay que modificar el configuration.php para cambiar los permisos por defecto que tendrán los archivos y directorios.

    Buscais: $mosConfig_dirperms = '';
    Y lo cambiais por: $mosConfig_dirperms = '755';

    Buscais: $mosConfig_fileperms = '';
    Y lo cambiais por: $mosConfig_fileperms = '644';

    Listo.
  • Gracias por la aportación, monki ;)

    Un saludo.
  • " Un apunte para quienes con Joomla 1.0.11 no consiguen instalar componentes o módulos de ninguna forma, ni siquiera con el parche.

    Yo con el parche no puedo instalar el zip así que lo intenté manualmente desde directorio (donde se indica en la página de instalar componentes), subiendo los archivos a un directorio temporal y ejecutando la instalación siguiendo los pasos de un modo correcto.

    Me apareció una página en blanco con varios "Warnings" populares en internet, así que siguiendo la referencia de una web me fui al ftp y me encontre con que el componente sí estaba instalado pero los permisos de los archivos que había creado, que no de las carpetas (estas aparecen con 777), están en 0.

    Los puse en 777 y entré en la administración de la web, donde pude ver y configurar el componente correctamente ya sin ningún "Warning".

    Un poco raro, pero me ha sucedido las 2 veces que he ido a instalar un componente y las 2 lo he resuelto así; parece que no instala pero lo hace, aunque luego hay que pasarse a cambiar los permisos."

    Aportado por
    g1g4byt3
  • necesito ayuda con mi joomla no puedo instalar nada , he mirado por el foro pero no me funciona nada de eso
  • Hola jkarlos:

    ¿Qué problema tienes exactamente? ¿Subida de componentes? ¿Qué componentes son en concreto los que te fallan? Recuerda que, incluso con el parche del modo seguro aplicado, algunos componentes no funcionaran de ninguna manera.

    Saludos.
  • Hola, muy buenas;

    Añado algo de "consulta" al tema, pues también estoy con esto de instalar Joomla (con el instalatron lo he puesto) y no hay manera de instalar ningún componente, me explico mas detalladamente.

    La versión de Joomla, es la 1.0.11, la que me instala el instalatron; le he colocado el parche del Safe mode, para esa misma versión, 1.0.11, y me aparecen las lineas para sumar el FTP assist option. Pero no hay manera. Ni subiendo los archivos desde mi PC, ni dejándolos en un directorio temporal. Siempre falla con los permisos, me dice que no puede mover los archivos (los permisos de los directorios están bien puestos, a 777, los que salen en la lista), pero no hay manera.

    Y ahora, intentando aplicar el idioma, me aparece esto, dentro de las opciones de lenguaje.

    Warning: file_get_contents(/home/buenrollo/domains/emule-buenrollo.com/public_html/language/spanish.xml) [function.file-get-contents]: failed to open stream: Permission denied in /home/buenrollo/domains/emule-buenrollo.com/public_html/includes/domit/xml_domit_lite_parser.php on line 1079


    No sé si el parche no es valido del todo. Estoy hasta por probar la nueva version 1.0.12 que ha salido. No se que hacer. Supongo que algunos componentes no se pueden instalar, pero es que no puedo poner ni el idioma. Incluso si pongo los archivos manualmente en la carpeta leguajes (basándose de como estan puestos en el portal, montado en local) y lo elijo dentro de la configuracion general, y no se pone, sigue esto en inglés.

    Tanto afecta el Safe mode, o es que hay algo mas.

    Busco desesperadamente ayuda, muchas gracias. Si alguien me da alguna pista, se lo agradezco de corazón :)

    Saludos
  • Hola buenrollo,

    En cuanto a la instalación de paquetes de idioma no hay problemas documentados, en las instalaciones que he echo personalmente tampoco he tenido inconvenientes en la versión 1.0.11 de Joomla.

    Si en cambio con algunos componentes o modulos que aun con el parche para SafeMode no son compatibles y no pueden utilizarse.

    Envianos un ticket de soporte para efectuar algunos cambios en los permisos que pueden ayudar con el problema que tienes, en caso contrario podriamos instalar nosotros directamente el Joomla en la carpeta que nos indiques con el pack de idioma castellano y parche para safemode on.

    Saludos
  • Os envio un ticket con los detalles, ya que no se que hacer (seguro que al final era algo simple).

    Muchas gracias por responder tan rápido :)

    Saludos
  • Hola a todos, puede ser que no funcionen las direcciones de los parches? me piden contraseña las 2 ultimas direcciones
  • Hola atletavet,

    Envianos un ticket de soporte y te indicamos una URL de descarga, dinos en el ticket la versión de Joomla que utilizas.

    Saludos
  • Hola atletavet:

    Ya te hemos respondido en el soporte con una URL privada para que puedas descargar el parche.

    Un saludo.